CDOT InRoads XM Project Defaults %

DEPARTMENT OF TRANSPORTATION

Management

This document is specific for CDOT’s implementation of InRoads XM. It describes the use of
preconfigured InRoads Project default settings, the benefits of using them, and how to manage the
resources and directory structure(s) they reference.

InRoads project defaults perform two functions; firstly they load the appropriate CDOT standard
resource files such as the standard XIN file, annotation resources, XML style sheets, etc.
Additionally they define default paths to project specific directory folders that contain project
data such as DTM'’s, alignments, survey data, etc. The workflow shown below utilizes a Project
Configuration File (PCF) which is created at the start of a project. This PCF file is created by
running the Project Creation Utility. The resulting PCF stores system variables to simplify file
management for the user. This PCF file is utilized by both the MicroStation and InRoads
environments.

PCF files are extremely useful when multiple users are accessing the same project directory
across the network, or when DGN files are moved from one directory to another. See the CDOT
workflow document Project Directory Creation and Management.pdf for information specific to
the creation and management of the PCF file.

The Registry File

A preconfigured file is delivered with the XM release of CDOT’s configuration. The user must
access this file only once from the InRoads interface. After the initial access, the project defaults
will be defined for all projects the user accesses on a specific computer.
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1. To access the configuration file, launch InRoads XM and open the Project De-
faults dialog by selecting File>Project Defaults from the InRoads interface.

h Set Project Defaults

Configuration Mame:
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Frojectize Directan:
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Template Libraries [ it]:
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2. Click on the Import button
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3. Browse to:
C:\Workspace\Workspace-CDOT_XM\Standards-
Global\InRoads\Preferences
select the file:

CDOT_XM Disciplines.reg

Look, if: ]j Preferences __"_i . IfT‘ EH-
E 3. IIIECDOT_XM Disciplines.reg
My Recent
Documents
ri_ -
Desktop

\$

tdy Documents

ter

£ &

File narne: ]EDEIT_XM Dizciplines.regq ;i I Open I
Fy Network  Files of type: ]Hegistration Files [*.req) :_! Cancel

Places
Help
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4. Click on the Open button and three things happen; Configuration Name, De-
fault Preferences and Default Directory Paths fields are populated.

b 5ot Project Defaults

1l

Configuration Name: £DOT Utiities Discipline - pyey
I Default Preferences Cloze
Mewe..

Freferences [".xin) $[CDOT_PREFNCDOT_Civil vin Copy...
Turtouts [ tat]: Rename...
Drainage Structures [*.dat]:

Rainfall Data [*.idf]:

Drelete

Browse...

Bridge Sections [*.kxt]
i Impaoit...
Drafting Motes [7.dft]: FCOOT_WESP)4Standards-GlobalnR oads\MoteshCDOT-Motes. ¢

Export...
Pay Items [*.mdb):

Help

Drefault Directory Paths

Praject Default Dirscton: | $iM5_DEF)Utitiess

Report Directory: $[MS_DEF)UtiitieshnR oadsh
Projects (*. k) $MS_DEF]Utiities nRoads'
Surfaces [*.dim]: $iM5_DEFUtilities\ nFoadsh

Geometry Projects [*.aldl | 41MS_DEF)Utltes\ nFoadsh
Template Libraries [t} 4t45_DEF)tiities\nRoadss
Fioadway Design [*ird]: $[MS_DEF|Utlities\ nR oads

Survey D ata [* fwd]: $IMS_DEF)
Crainage [*.=db): $MS_DEF)
Style Sheet [*.xal): C:Wworkspace'workspace-CO0T_xkM4\Standards-GlobalnR oadsh<ML Style Sheetsh

Quantity Manager ["mdb): | ${MS_DEF|Utlities\ nRoads

Default Grid Factar Esport
GridFactor |1 oo [] Active Only

Default Directory Paths are defined on a CDOT Discipline basis.
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Setting Project Defaults

1. Users can use the Configuration Name field to choose the appropriate discipline
for the location of their data files.

B ot Project Defaults

Configuration Hame:

Drefault Preferences

Preferences [*.xin);
Turnouts [ txt]:

Dirainage Structures [~ .dat)
Fiainfall T ata [~ idf):

Bridge Sections [* kat):
Dirafting Motes [* dit]):

Fay Items [*.mdb]:

Diefault Directony Paths

Project Default Directany:
Report Directarny:
Prajects [*.nwk]:
Surfaces [*.dim]:
Geometry Projects [*.alg):
Template Libraries [*.it]]:
Roadway Design [*ird):
Survey Data [ fwd]:
Dirainage [*.=db):

Style Sheet [ uzl]:

Guantity Manager [*.mdb):

Default Grid Factor
Grid Factor: 1.0000

COOT Utiities Dizcipling w

Apply

<M arner

CDOT Bridge Discipline

CDOT Design Dizcipline

COOT Environmental Dizciplineg

CDOT Hydraulics Discipline

COOT Landzcape_Ernvironmental Discipline
CDOT Materials_Geotechnical Discipline
COOT RO _Survey Discipline

CDOT Traffic_ITS Discipline

COOT Utilities Digcipline

1l

Close

Mew...

Copy...
Rename...

Delete

FC0OT_wESPMStandards-GlobalnR oads\MWatesh COOT -Mates.c

$IMS_DEF U titiesh
$IMS_DEF)Utities' nFinads'
$[MS_DEF|Utiitiesh nFioads'
$IMS_DEF)Utities' nFinads'
$[M5_DEF|Utitiesh nFioads'
$[MS_DEFUtiitiesh nFioads'
$[MS_DEFUtitiesh nFaads'
$[M5_DEF)

$[MS_DEF)

Browse. ..
Impaort...
Expart...

Help

pERArE

C:\workspace\workspace-CDOT_x<M\Standards-GlobalslnF oads\=kL Style Sheats'

${MS_DEF)Utilties s nR oads,

E=port
[] &ctive Only
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2. By selecting a discipline specific Configuration Name, the path to for Default
Directories is appropriately changed.

H Set Project Defaults

Coviilsisten Wenis CDOT ROW_Suivey Disciplne v Apply
Diefault Preferences Blle=Le
(=)
Freferences [* xin]: ${COOT_PREFICDOT_Civil xin Copy...
Turnouts [ k=t]: Fename. .

Dirainage Structures [*.dat): Delete

Rainfal D ata [ idf:

Bridge Sections [* tat):

VR

Imparl

Drafting Motes [*.dft): $[COOT _wkSP\Standards-GlobalInFoads'\Motes\COOT-Motes.c
Pay Items [*.mdh):

[_Hep |
Default Directory Paths
Project Default Directary: $(M5_DEFINROW_Survey',
Repart Directary: $(MS_DEFIROW _SurveInFoads\Repartsh,
Projects [".nokl: ${M5_DEFIROW _SurveytinFoads'
Surfaces [*.dim): $[5_DEFIROW SurveytnRoads\D T
Geomety Projects (“alal  §MS_DEFROW _SurveyMnRoads\Geometry
Ternplate Libraries [*it]): $(M5_DEF)
Roadway Design [*ird): $[M5_DEF)
Survey Data [ fiud]; $IMS_DEFIROW_SurveytInFoads'Field_Books'
Drainage [*.sdb): $[M45_DEF)
Style Sheet [*xsl): C:\wiork spacewiorkspace-COOT _xM\Standards-Global\InFoads =ML Style Sheets",
Quantity Manager (.mdb) 45 _DEFIROW_Survey\InA oads\Reportsh

Drefault Grid Factaor Export
Grid Factor. |1 gono [ &ctive Orly
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3. The Default Preferences which load the standard CDOT configuration resources
as well as the location of the XML Style Sheets are common to all disciplines

B 5t Project Defaults

Configuration Name: |COOT Design Discipline v Apply

Default Preferences Cloze

=
]
=

ST

Freferences ["xin) $(CDOT_PREFNCDOT_GCivil vin Copy...
Turrouts [ tat]: Rename...
Drainage Structures [*.dat):

Rainfall Data [*idf):

Delete

Browse...
Bridge Sections [*.tat]
i Impaoit. ..
Drafting Motes [ dft]: FICOOT_WESP)AStandards-GloballnR oads\MoteshCDOT-Motes. ¢

Export..
Fay Items [*.mdb):

Help
Default Directory Paths

Praject Default Dirsctons | 4iM5_DEFIDesian’

Report Directory: $[MS_DEF)DesigniInRoadsy
Frojects [*.rwk]: | $M5_DEF|DesigntnRoads!,
Surfaces (. dim]: | $(M5_DEF)DesigntInFoadsh

Geometry Projects [.aldl | 41MS5_DEF)Design'InFoadsh
Template Libraries [*itl]: $[MS_DEF|DesigntnR oadsh
Fioadway Design [*ird]: $[MS_DEF|DesigntnRoadsh

Survey Data [*fwd]: $[MS_DEF)
Drainage [*.=db): $MS_DEF)
.
Style Sheet [*.xal): C:¥workspace'workspace-CO0T_Xk4\Standards-Global\nR oadsh<ML Style Sheets'

Quantity Manager [~mdb): | ${MS_DEF|DesigntinRoadsh

Drefault Grid Factar Export
GridFactor |1 oo [ Active Only

4. Three variables are used to facilitate the use of Project Defaults. Two of these va-
riables are not impacted by interaction by the user.
$(CDOT_PREF) defines where the InRoads XIN file (master settings file) is
stored.
$(CDOT_WKSP) points to the installation location for CDOT’s configuration.

$(MS_DEF) defines the project currently being accessed.

This variable is defined by individual users when opening a MicroStation file
through the MicroStation Manager interface.
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Using Project Defaults

1. To realize the benefits of using project defaults, in the Set Project Defaults di-
alog, select any discipline from the Configuration Name drop-down list. Then

Select the Apply & Close buttons.

!‘1 Set Project Defaults

Configuration M ame:

Default Preferances

Preferences [* =in]:
Turnouts [ bt):

Dirainage Structures [*.dat):
Rainfall D ata [*.idf]:

Bridge Sections [*.tut]:
Dirafting Motes [*.dft):

Pay Items [*.mdb):

Default Directory Faths

Praject Default Directory:
Repart Directorny:
Projects [* nak):
Sufaces [*.dim]:
Geometry Praojects [ alg):
Template Libraries [*itl]:
Foadway Design [*.ird):
Survey Data [* fwd]:
Dirainage [* zdb):

Style Sheet [*.xsl):

Quantity b anager [*.mdb]:

Default Grid Factor
Grid Factor: 1.0000

CDOT ROW_Survey Discipline £V

o
=

$ICDOT_PREFICDOT_Civil xin Copp..

Rename...
Delete

Browse...
Impaort....

$ICOOT _wWESP)\Standards-Global\ nRoadsWMotesh\COOT-Motes.c
Export...

Help

$(MS_DEFIROW_Surveyt,

$IM5_DEFIROW _SurveptlnRoads'\Reports
$(MS_DEFROW_SurveptInRoadsh
$(MS_DEFIROW _SurvepilnRoads\D Tk
$(M5S_DEFIROW_SurveytInFoads\Geometnys
$[MS_DEF)

$IMS_DEF)

$IMS_DEFIROW _SurvepdlnRoads\Field_Books'
$[MS_DEF)
C\workspace\Wworkspace-COOT_=<M\Standards-GlobalnF oads'e<kL Style Sheets'
$M5_DEFIROW _SurveptlnRoads'\Reports

Export
[ sctive Orly

2. From the InRoads interface, select File>Open
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( Bentley InRoads X# Edition |[=] <
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3. Note the active project and discipline folder is now defined

Open

[e

My Recent
Documents

¥
Deszktop
My Documents
e
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tdy Computer
)
-
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Flaces
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% My Recent Documents
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by Copmyter
“ge Local Disk [C:]
) Projects
) 16704

i Audio CD [E:)
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[

Files of type:

| InRioads Files k" dim.? alg it " sdb.” v |

4. By choosing the desired Files of Type: the Look In: field updates to the appro-
priate folder for the active project.
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The First Step - Setting the Project Default

E;-.’j MicroStation Manager

File Directory Help
Files: Directonies;
[ C:AProjectsh16704%

AN -
[ Projects
= 16704
3 Bridge
£3 Construction
£ Consultants
3 Design
3 Hydraulics
3 Landscape_E nvironmental
3 Materials_Gectechnical
3 Mizcellaneous

3 Planning ﬂ

List Files of Type: Dirives:

CAD Files [*.dan,* dwg " df] x| BT I:I
[~ Bead-Only Cancel

[~ Show File lcons

3D -V3DGN

Kl

Workspace

" Lser. |[COOT User b
e Froect (16708 -
=

Interface; |COOT Z|

a

1. Inthe MicroStation Manager dialog, the Project (PCF file) can be selected from
the Workspace portion of the dialog box on the Project pull-down menu which
will navigate you to the appropriate project folder and define the MS_DEF vari-
able.

2. Asseen in the InRoads Project Default dialog, this variable (MS_DEF) is used to
as a prefix to automate folder locations used by InRoads.

Note: Refer to the graphic in step 6 to review the folder paths utilizing the
MS_DEF variable.

Note: The graphic below shows the contents of a PCF file and how the
MS_DEF variable is defined. By editing this ASCII file users can customize
the MS_DEF variable. This would be necessary if your folder structure
changes and/or files are moved to different a different location such as to a
project managers machine or external hard drive.
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"2 16704.pcf - Notepad JoEd

File Edit Format View Help

iy - 2 O L

= =
MS_DEF=C: /Projects/16704/ |
ke T T T l_.l-:C -
MS_RFDIR=3(MS_DEF)
MS_RFDIR=3(MS_DEF)Eridge/Drawings/
MS_RFDIR=3(MS_DEF)Eridge/Drawings /Reference_Files/
MS_RFDIR=3(MS_DEF)Construction/Drawings/
MS_RFDIR=3(MS_DEF)Construction/Drawings /Reference_Files/
MS_RFDIR>3(MS_DEF)Landscape_Environmental/Drawings/
MS_RFDIR=3(MS_DEF)Landscape_Environmental /Drawings /Reference_Files/
MS_RFDIR=>3(MS_DEF)Hydraulics/Drawings/
MS_RFDIR>3(MS_DEF)Hydraulics/Drawings /Reference_Files/
MS_RFDIR=3(MS_DEF)Materials_Geotechnical/Drawings/

MSZRFDIR>_(MS DEFJMaterials_Geotechnical/Drawings /Reference_Files/
MS_RFDIR>3(MS_DEF)Design/Drawings/

MS_RFDIR=3(MS_DEF)Design/Drawings /Reference_Files/
MS_RFDIR=3(MS_DEF)ROW_SURVEY,/Drawings/
MS_RFDIR>3(MS_DEF)ROW_SURVEY/Drawings /Reference_Files/
MS_RFDIR>3(MS_DEF)Traffic_ITS/Drawings/
MS_RFDIR=>3(MS_DEF)Traffic_ITS/Drawings/Reference_Files/
MS_RFDIR=3(MS_DEF)UtiTities/Drawings/
MS_RFDIR=3(MS_DEFJUti Tities /Drawings/Reference_Files/

MS_PLTFILES=3(MS_DEF)Plot_Sets/
MS_DGNOUT=3% (M5_DEF)
MS_IMAGEOUT=3(MS_DEF)

#

#
COOT_WKSP=C: /Workspace/Workspace-CDOT_>M/
COOT_PREF=%(CDOT_WKSP) /Standards -Global/InRoads /Preferences/

See the CDOT workflow document CDOT Project Creation and
Management.pdf for more detailed information on working with the PCF file.
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